This is an alert box.
Header ImageStatus Page for AWS
US East 1 - Multiple Services
Incident Status: Resolved
Components: Compute, Databricks SQL, Delta Live Tables, Model Serving, Notebooks, Workflows
Locations: US East 1
Updates
Resolved
April 5, 2025 00:32 UTC
Between 22:45 UTC and 23:23 UTC April 04, 2025, customers may have experienced failures while attempting to launch cluster and serverless compute resources. Customers may also have experienced failures while running Databricks SQL queries, launching and using Model Serving endpoints and running DLT pipelines. The incident is now closed. If you require further details about this incident, please submit a support ticket or contact help@databricks.com.
Monitoring
April 4, 2025 23:54 UTC
Between 22:45 UTC and 23:23 UTC on April 04, 2025, customers may have experienced failures while attempting to launch cluster and serverless compute resources. Customers may also have experienced failures while running Databricks SQL queries, launching and using Model Serving endpoints, and running DLT pipelines. The issue has been mitigated. We will continue to monitor the platform and will provide a final update in 1 hour.
Identified
April 4, 2025 23:38 UTC
Starting at approximately 22:45 UTC April 04, 2025, customers may experience failures while attempting to launch cluster and serverless compute resources. We identified the issue, and we're working on potential mitigation paths. Further updates will be provided in 1 hour, or as events warrant.
Investigating
April 4, 2025 23:05 UTC
We are actively investigating an issue with the Databricks service. Further updates will be provided within the next hour, or as events warrant.

Back to current status